Creating Dialog Based Applications with MFC 7
By Jason Pursell, University of Washington, Bothell (2000-2003)
jpursell@u.washington.edu

Introduction

This tutorial demonstrates how to create a simple dialog based application with MFC
7 and Visual Studio .NET.

Note: | originally created this tutorial to aid my classmates in using Visual Studio
.NET and MFC 7 during the 2002 school year when many students were still using
Visual Studio 6 and MFC 6. It should also be noted that this tutorial is based on
another one from CodeProject.com, A Beqginners Guide to Dialog Based
Applications — Part One, by Dr. Asad Altimeemy. Please check that one out if you
are interested in using Visual Studio 6 and MFC 6, because | will focus solely on MFC
7 in this tutorial.

The Visual Studio .NET IDE

Visual Studio .NET allows multiple programming languages to share the Integrated
Development Environment (IDE), so there are new parts to the IDE that are common
to all the languages, and some familiar parts are gone or replaced (see Figure 1 and
Table 1). For the purposes of this tutorial, | will focus only on the parts related to
MFC.
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Figure 1. Some parts of the IDE that are new and/or improved.


mailto:jpursell@u.washington.edu
http://www.codeproject.com/dialog/dialogapptute.asp
http://www.codeproject.com/dialog/dialogapptute.asp

Salution Explorer = mfcTTest

o) W 4 = {1 mfcTTest
* -

=[] mfcTTeswre
%4 Solution ‘mfc7Test' (1 project) # || = Diakog1 & =[] Diakeg
= (A micTTest + -y Gobal Fupetioes s Viishiss B oo_ssouTec:
= 3 rﬂ s ¥ B Mooros and Constants =] 00 MFCTTEST DIALOG
|£] mfc7 TestCl.cpp 3 zz CTJ:-:.-.tI:-; T _IEnm_wnrM
|#] stdafx.cpp i e = [ RT_MANIFEST
= 23 Header Files = : T 1DR_MANIFEST
[ Rescurce.h ¥} Bases and Interfaces =[] Strirg Table
] mfc7Test.h H- ¥ Maps aba String Toble
|] micTTestoig.h ¥l _urnaved_|1es0isd_| 5 Verson
[ stdafs.h § CDiglogiDigi Cwined “pParent =0) 3 *5_VERSION_INFO
= &3 Fﬁmﬂ:? o DeDataExchange{ ChataEnchange "0} B -
CFTash, ) =
j mic?Tost. mankes: :we;ww; ¥
,ﬂ mfe T Tast.re e 5
- 1 mifr 7 Test 2 — —
(o Sohutio. . 155 F w T class view | 5 0 sohuto.. | S Class v... ElResaur.. |
Solution Explorer Class View Resource View

IDE Component Description

— Displays a variety of items for use in Visual Studio
1. Toolbox projects such as controls, components, and code/text
fragments.

— This is where you create or edit dialog box resources.

2. Dialog Editor (MFC) Beware — this is not Windows Forms!

— Provides you with an organized view of your projects
3. Solution Explorer and their files as well as ready access to the commands
that pertain to them.

— Displays a programmatic view of symbols in your code,

4. Class View for example, namespaces, classes, methods, and
functions.
5. Resource View — Displays the resource files included in your projects.

— Use this window to view and change the design-time
6. Properties Window properties and events of selected objects that are located
in editors and designers.

Table 1. IDE components.

The location of the each of the views (or windows) is totally dependent upon the
profile you are using. The profile can be set from the Start Page under My Profile.
The Start Page usually shows when you start Visual Studio .NET.

The properties window is new and its buttons are important (Figure 2). The first
two on the left just determine how the items are displayed in the list. The next three
determine what is displayed: Properties, Control Events, Messages, or Overrides (in
that order). Control Events, Messages, and Overrides are only available when certain
things are selected. For example, Figure 2 is what is available when CDialog1Dlg is
selected in the Class View (as in the picture of the Class View at the top of the
page); however, the Overrides icon is only shown when a class is selected.
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Figure 2. Buttons of the properties window.




Creating a New Project (and Solution)

To create a new project, choose File>New->Project on the main menu. The New
Project dialog will open.
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Figure 3. New Project dialog.

Write Dialogl in the project Name field.

Specify the Location for the Solution and project to be created. Choose a new
location if you don’t like the default (usually in My Documents/Visual Studio Projects
or it might show the last place that you created a project).

If you don’t see the New Solution Name field as in Figure 3, then click the More
button. Change the name of the solution if you want, otherwise it will default to the
same name as the project. The solution will be in the same folder as the project.
This is alright if the solution will only have one project; however, if you know that
your solution is going to have more than one project in it, then check the Create
directory for Solution checkbox. This will create a folder with the name of the
solution and it will contain the files in Figure 4. If you don’t check the Create
directory for Solution checkbox, Dialogl.sIn, Dialogl.ncb, and Dialogl.sou will just
go in the Dialogl project folder.

. .sln — Solution File
¥ ] .ncb — Intellisense Database
’,J 8 _d 4 .sou — Solution User Options
1 -

Dialogl.nch Dialogl.sln Dialogl.suo

Figure 4. Files created inside the Dialogl solution folder when the Create directory for Solution checkbox
is selected.



Note: The Dialogl.sin file is somewhat analogous to the DSW file in Visual C++ 6
(i.e. this is what you double-click to load the entire solution in the future).

Click the OK button when ready. The MFC Application wizard will start.

On the menu, choose Application Type (circled in red in Figure 5).
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Figure 5. Page one of the wizard.
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Figure 6. Application Type page of the wizard.
Choose the options that are circled in red in Figure 6.

Click the Finish button.

Note: Feel free to look at the other pages; however, for this tutorial we will accept
the defaults.




Designing the Dialog

Note: If the Dialog Editor is not showing, open the Resource View (Ctrl+Shift+E)
and expand the Dialog folder, then double-click IDD_DIALOG1_DIALOG.
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Figure 7. The Dialog Editor in action.

Click on the text TODO: Place dialog controls here, then press Delete.

Next, as in Figure 7 above, select the dialog by clicking on the edge of the title bar.
The dialog will now have sizing handles on its sides and corners. These are used to
resize the dialog. The width and height of the dialog is indicated at the bottom-right
of the IDE and is circled in blue in the diagram above. Left-click and Drag the
bottom-right selection handle up and to the left until the size of the dialog is at a
width and height of 230 x 126, then release the mouse button. Note that there is
nothing special about these dimensions. They are just the numbers that allowed me
to fit the controls on the dialog in a “nice” manner. ©

Since we don’t need the Cancel button in our application, select it by left-clicking it
once. The button is selected when sizing handles surround it. Press Delete.

Next we need to change some of the properties of the OK button.

Select the OK button by left-clicking it once. Figure 8 shows how the Properties
window reflects the properties of the button when it is selected.

Note: Depending on your choice of IDE setup, the Properties window might be on
the left or right. If it is not showing, then choose View->Properties Window from
the main menu or press F4 on the keyboard.
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Figure 8. Properties of the OK button.

Change the Caption of the button by typing Close in the value field of the Caption
property (Figure 9 on the next page).
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Figure 9. Changing the Caption property of the button.

Now the button on the dialog reads “Close”.




Adding Controls

Next, you will add some new controls to the dialog. Our example will have nine
controls in total. These controls are located in the Toolbox window. Using these
controls, we will create a dialog similar to the one in Figure 10 below.

Note: Depending on your choice of IDE setup, the Toolbox window might be hidden.
By default it is on the left side of the IDE. If it is not showing, then choose
View->Toolbox from the main menu or use the Ctrl+Alt+X keyboard shortcut.

Dialog1 (%]

fdd

Title First Mame Last Mame

sample list box

Figure 10. Example layout of the Dialogl dialog.

To select a control from the toolbox, left-click it once to select it and then place it on
the dialog by left-clicking in the general area of where you want it positioned. You
can also just drag a control from the Toolbox to the dialog. Try both ways to see
which you prefer.

As an example, the first control we add to the dialog will be a new button.
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Next we will change a couple of the properties of the new button. First, select the
button on the dialog. Next, in the Properties window, change the following
properties of the button:

Property Value
ID IDC_ADD
Caption Add

The ID property determines how the each control is identified by MFC in code. Every
control must have an ID. You will see how this works later in the tutorial.

Start Page  Dialogl.re (ID...ALOG - Dialog)* | Il Froperties I X
[T o | | | | | | | IDC_ADD (Button Control) IButtonEditor |
S o2 . 7
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'mnup T p—
-
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| | Specifies theidentifier of the contral.
4 3

Next, the Caption property is what is displayed on the control and is what the User
will see when using the application. Not all controls have a Caption property.
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Use Table 2 on the next page as a guide to add the remaining controls to the dialog.
As you add each control to the dialog, change its properties to the values shown in
the table just as you did for the Add button. Again, we want to build a dialog similar
to Figure 10 above.



Control Property Value

Static Caption Title

Static Caption First Name

Static Caption Last Name

Edit ID IDC_FIRSTNAME

Edit ID IDC_LASTNAME
ID IDC_TITLE

Combo Box Data Mr.;Mrs.;Miss;Ms.;Dr.
Type Drop List

List Box ID IDC_NAMELIST

Table 2. The controls and their properties that we want to change.

Please see Figure 11 for an example of the property settings for the combo-box.

Here is an example of the properties of the combo-box control that we added. The
properties we will change are highlighted in red.
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Figure 11. The properties of the IDC_TITLE combo box control.

Next, we need to specify the length of the combo-box drop down list. Position the
mouse over the drop-down arrow of the combo-box and left-click once. Use the blue
resizing handle to adjust the length, similar to Figure 12. Click the drop down
arrow on the combo-box again to toggle back to the normal control resizing mode.
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#

Add Close

Title /EFQI: Mame Last Name
] ;'+ I ple edit box I Sample edit box

~.

1. Left-click to toggle the
sizing mode.

@M/ 2. Use to adjust the length.

Figure 12. Specifying the length of the open Combo-box list.

Hint: When a control on the form is selected, you can “nudge” it by pressing one of
the arrow keys on the keyboard. This provides finer adjustments of the control’s
placement than is possible by using the mouse. Likewise, you can grow or shrink
your control by holding down the Shift key and then pressing one of the arrow keys.
This is an alternative to using the resizing handles. Try these techniques as you
create this dialog.

Assigning Member Variables to Controls

Let’s add some variables to tie the GUI to the data. Make sure that the Dialog Editor
is open and active. In order to access the Add Member Variable Wizard, choose
Project->Add Variable from the main menu. You can also right click anywhere in
the Dialog Editor and choose Add Variable from the pop-up menu. This is fine for
regular old variables, but for variables that represent controls, you should right-click
on the control. This way the Add Member Variable Wizard will start and it will load up
with the fields already filled with the default settings for that control.

Dialegl.re (IDD..TALOG - Dialog) | CialoaiDioh | Cistog 10l con
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- Title First Wa
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[%  Add variatie... —

¥ Check Mremonics
S Properties

Figure 13. Right-click menu.
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We will work with the First Name Edit control first.

In the Dialog Editor, right-click the First Name Edit control. From the pop-up menu,
choose Add Variable.

As in Figure 14, make sure the following settings are present before pressing the
Finish button: Control variable checked, Control ID to IDC_FIRSTNAME, Access to
private, Category to Value, Variable to CString, Control type to EDIT, and Variable
name to m_strFirstName.

Add Member Variable Wizard - Dialog1

Welcome to the Add Member VYariable Wizard
This wizard adds a member variabbe bo vour class, struct, oF union.

e
ﬂ:lrh'd:e || M Control variable
yarishle bype: Conbral J: Category:

| C5tring | | IDC_FIRSTHAME | |value |
arkeble pame Conkrolbpe: Mg chars:

[in_steFstiame [EDIT [

Compent ] rotation nok required):

l-_rish|l‘.'ance||HEbI

Figure 14. The Add Member Variable Wizard for the First Name edit control.

Use table 3 as a guide to enter the other variables.

Control ID Access Variable Variable Name Category Control Control
type type variable
IDC_LASTNAME | private CString m_strLastName Value EDIT yes
IDC_TITLE private CString m_strTitle Value COMBOBOX yes
IDC_NAMELIST private CString m_strFullName Value LISTBOX Yes
IDC_NAMELIST Private CListbox m_NameList Control LISTBOX yes

Table 3. The remaining variables that need to be added via the Add Variable Wizard

Remember: Right-click on the control to add a variable. There are other ways, but
this is the easiest for you, because it “pre-fills” some of the fields.

Note: IDC_NAMELIST has two variables for it. The CString variable has a category
of Value and the CListbox variable has a category of Control.
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Adding Message Handlers for the Controls

There is more than one way to add an event handler. 1 will show a couple of ways
here. Each has their pros and cons. Both of the methods refer to the Add button.

Note Read over both methods first and then decide which one you want to use.

Method One

Right-click on the control that you are interested in (the Add button in this case),
then choose Add Event Handler from the pop-up menu (see Figure 15). This will
bring up the Event Handler Wizard. There you can fill in the information.

For the Add button the Message Type is BN_CLICKED, the Class list is CDialog1Dlg,
and the Function handler name is OnAdd.

¥ Delete
| AddEventHander...
Insert ActiveX, Contral...
=3 Add Class...
s Add Varisble. ..
Size bo Conkent

Check, Mnemonics

B <¢

Properties

Event Handler Wizard - Dialog1

Welcome to the Event Handler Wizard
This wizard adds a menu or stoelarabor comirand hander or disleg control evert hardier bo the ;
class of your choice. .
|
Message bype: Chass st
EINETE= S -~ cﬁ- ‘ﬁ
BT B R TCRED,
BN_KILLFOCLS ¥ | JCAboutDig
Function handier name:
fomadd]
|
| edtcsde | coed | e |

Figure 15. Accessing the Event Handler Wizard from right-clicking on controls.
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Click the Add and Edit button when done. This will take you to the newly added
method where you can begin adding your own code.

Method Two

The second method is done through the Properties window and is very convenient.

First, left-click on a control to select it. The Properties window will change to

represent the control. Click the Control Events button. Next, click on the

BN_CLICKED control event.

As soon as you press Enter, the main window will change to code view and the

If you click the down arrow, you will see Figure 16.
We want to use our own name, so instead, just type in the field as in Figure 17.

cursor will be positioned in the newly created method waiting for you to add some of

your own code.

The code that you will add is on the next page.

Properties Q

X

I IDC_ADD {Button Control} IButtonEditor

=

5 (4 7
BCN_HOTITEMCHANGE

BN_CLICKED

BN_DOUBLECLICKED | <Add> OrBnClickedadd

Control Events
Button

Don’t choose this
unless you want the
function to have the

BN_KILLFOCUS
BN_SETFOCUS
WM _THEMECHARGED

default name.

Figure 16. The default event handler function name provided by MFC.

Properties =}

x

| IDC_ADD (Button Control} IButtonEditor
8 #
ECN_HOTITEMCHAMNGE

[~

BN_CLICKED Onadd] <

BN_DOUBLECLICKED
BN_KILLFOCUS
BN _SETFOCUS
NM_THEMECHANGED

=i

We want to use our
own name, so just
left-click once in here
and type: OnAdd
Then press Enter.

Figure 17. Accessing the Add Event Handler through the Properties window.

Now that you’ve read through both methods, follow one to add an event handler for

the Add button.
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Add the following code to the OnAdd function:

void CDialoglDIlg: :OnAdd()

{
// TODO: Add your control notification handler code here

CString strTitle;
int nindex;

UpdateData(); // DDX - Transfer data from the controls to variables
//get the currently selected text

nindex = GetDIgltemText(IDC_TITLE, strTitle);

m_strFullName = strTitle + ™ " + m_strFirstName + " " + m_strLastName;
m_NameList.AddString(m_strFul IName);

UpdateData(FALSE); // DDX - Transfer data from variables to controls

Building and Running the Program

To run, just press CTRL+F5 or Debug->Start Without Debugging. Choose “Yes”
when asked to rebuild the files.

Hint Using Start Without Debugging is much faster than Starting (with
debugging). This is especially true when compiling C# or VB.NET programs in
Visual Studio .NET. The debugger is very powerful, though, so when you need
it just choose Start (or F5).

2% Dialog1 - Microsoft Visual C++ [design] - Dialog1Dlg.cpp

File Edit View Project Build | Debug | Tools Window Help
@ - HE@ X Windows >
S T ’s |
% Dialogl.rc (IDD_...DIALOG - Dialg ! Start Without Debugging Ctr+FS
W |¢* |_= Processes. .. —
3 L
i T ; 5%, Exceptions... Ctrl+8lt+E  ©
al 158, return s et
-1 159, } 5F Step Into F11
2 160 [E step Over F10
161 woid Clhialog
162 { M  New Breakpoint... Ctrl+B
o 163, /1 TODO:| 0]
= 1645 // =end CTrrrsTIOCTICICHC IO WITTESS O 0%

Figure 18. Debug menu.
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If everything was done correctly, you should be able to type values into the fields
and press the Add button to copy the values into the Name list.

% Dialog1

The Widows XP theme
settings are in effect,
because MFC 7
Title Firsk Mame Last Mame automatically creates a
manifest file as part of
the resources.

(This can be disabled)

Mr. w | | Jason Pursell

It is only available on
Windows XP or better.

Figure 19. Example application.

Hopefully, this tutorial has been helpful in introducing you to Visual Studio .NET and
MFC. Please email any suggestions to me at jpursell@u.washington.edu.

My website is located at http://home.myuw.net/jpursell

Resources

For more help on getting started with Visual Studio .NET and/or MFC 7 please see
following:

- www.msdn.microsoft.com
- www.msdn.microsoft.com/library/default.asp?url=/vs/techinfo/Default.asp
- www.codeproject.com

- www.gotdotnet.com

The MSDN library that comes with VS .NET also has gigabytes of help on how to use
the IDE and MFC 7. It also contains whitepapers on compatibility issues between
MFC 6 and 7 and general standards conformance with “Standard C++" (which is
much improved).
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