EE 400/546: Biological Frameworks for Engineers
                                                                 Handed out on 3-1-05; due on 3-8-05


A Mathematical Model of the Cardiovascular System


In lecture, we’ve briefly discussed the fact that muscle cells depend on the delivery of nutrients and the removal of waste products by the cardiovascular system.  This tutorial, a homework assignment due on March 8th, will help you explore the cardiovascular system in greater detail.

INTRODUCTION


The cardiovascular system consists of the heart (the “cardio-” part) and the blood vessels to which it is connected (the “-vascular” part).  The heart is a special type of muscle; when it contracts, blood is squeezed out into the blood vessels, which carry the blood through the body and then return it to the heart.  The anatomy of this system and the control of blood flow are so complex that it is difficult to keep track of all the important factors and how they affect each other.  To improve our understanding of complex systems such as this one, biologists often build mathematical models, which can be used to predict the behavior of a complex system.  A model can be very useful in situations when you have some knowledge of the components of a system but aren’t sure what will result from the components’ interactions with each other.  In these cases, you can incorporate all of the components into a model and then let the model calculate what happens to the system as a whole.  Models thus allow you to discover properties of a system that are not intuitively obvious but emerge from the nature of the connections between the components.

ASSIGNMENT


Follow the instructions below and answer all of the italicized questions.  Your answers are due on March 8th at 8:30 AM; please start the assignment as soon as possible so that you can get help (email crowther@u.washington.edu) if you run into trouble.


1.  Go to a networked computer onto which the Teranode Design Suite software has been loaded.  (You may have loaded this software onto a personal computer earlier in the quarter in preparation for the first lab.  Otherwise you can use one of the computers in the EE computer lab.)

2.  Copy the file “cardiovascular0305.vlx” from the class website (http://www.ee.washington.edu/class/400b/2005wtr/) to your hard drive.  This file contains the cardiovascular model that you’ll use for this assignment.


3.  Open the Teranode Design Suite.  (On most computers, you can do this by selecting Start => Programs => Teranode => TERANODE Design Suite from the Start menu at the bottom left of the screen.)


4.  From the menu at the top of the TeraStudio window, select File => Open…  Then select the cardiovascular0305.vlx file you added to your hard drive.  This should bring up a window containing a yellow sphere labeled “recirc.”


5.  Right-click on the “recirc” sphere and select “Open.”  This should bring up a graphical representation of the flow of blood through the body.  Let’s follow this flow, starting at the “Heart” sphere toward the bottom of the window.  From the heart, the blood goes through the Aortic Valve (which ensures that blood does not flow in the reverse direction) into the Aorta, a really huge blood vessel.  From the Aorta, the blood goes into the Arteries (somewhat smaller blood vessels).  In this model, flow is then split between the Muscles and the Gut.  Blood in the Muscles and Gut goes through numerous tiny capillaries and then is collected by the Veins, which return blood back to the Heart through the Mitral Valve.  Note that each part has an associated set of properties that can be viewed by double-clicking on the sphere representing that part.  Nevertheless, this model is a relatively simple one that omits many details – perfect for beginning biology students!


6.  To do anything interesting with this model, you need to understand the relationship between pressure, flow, and resistance.  The blood flow between one point and another is the pressure difference divided by the vascular resistance:

F = (P1 - P2) / R.

(This equation is the hydrodynamic equivalent of Ohm’s Law.)  You probably already have some grasp of the concepts of pressure and resistance.  In this model, the heart maintains a pressure head (P1) by contracting and sending the blood into the aorta under relatively high pressure.  This pressure is dissipated as the blood flows through the rest of the circulatory system because the blood vessels offer resistance (R) to the flow.  Resistance is strongly dependent on blood vessel width; the wider the diameter of the vessel, the lower the resistance.  We can control the resistance of some of our blood vessels by contracting or relaxing smooth muscles in the vessel walls.  Contracting these muscles narrows the lumen of the vessel and thus increases resistance; relaxing the muscles expands the lumen and decreases resistance.


Based upon the above equation, what are two ways in which blood flow to a particular tissue in the body could be increased?


7.  Pressures and flows can be measured or calculated in many different parts of the cardiovascular system: in the aorta, in the arteries, in the gut, in the muscles, in the veins, and in the heart itself.  To look at pressures and flows predicted by the model, first select “New Plot Page” from the Tools menu, click on the “Play” button ([image: image1.jpg]


) toward the top left of the window, and then pull down some variables to graph from the menu at the top right of the Plot Page.  The “spikes” in the graphs correspond to heartbeats, which cause sudden changes in pressure and flow.  

You can adjust these graphs in numerous ways.  For example, to add a new variable to a graph, click once on the graph and then select the variable you wish to add from the pull-down menu at the top right.  To remove a variable from a graph, right-click on the graph, select “Plot Properties,” highlight the appropriate variable, and then click “Delete.”  To change the axis ranges, select “Plot Properties,” go to the X-Axis or Y-Axis tab, select the Range tab, and make the appropriate adjustments.  You can also create a brand-new plot window by selecting “Tools => New Plot Page” from the menu at the top left of the screen.


8.  Beside the “recirc” tab there should be two other tabs: “Text” and “Math.”  If you look at each of them, you’ll see that these pages include all the coding and equations that constitute the model.  If you wanted to understand the model in great depth, you’d study these pages carefully.  The “Graph: recirc” page simply provides a visual overview of the model and allows you to change the values of the input variables associated with each component of the system.  You can adjust these values and examine the consequences by entering a new number into one of the “Properties” boxes, hitting the “Play” button, and looking for changes in the graphs on the right.


9.  OK, it’s time to start manipulating parameters!  Let’s imagine that we’ve started to exercise and we need to provide increased blood flow to our muscles (to deliver extra O2 and carry away extra CO2).  How much can we increase blood flow to the muscles just by changing heart rate (and thus increasing P1 in the equation above)?


Increase the heart rate from 70 beats per minute (a typical resting heart rate) to 110 (a typical heart rate during mild exercise), then hit “Play.”  What happens to the arterial pressure?  (Ignore the first second or two of the simulation, during which the model stabilizes. Give actual numbers; if it’s hard to estimate the numbers from a graph, you can right-click on a graph and select “View Data.”)  What happens to the blood flow to the muscles?  


Now increase the heart rate to 150, and then to 190 (typical heart rates during intense exercise).  What happens to arterial pressure and muscle blood flow? Does there appear to be a maximum pressure (and thus a maximum flow)?  If so, it may be explained by the fact that, the faster the heart beats, the less time it has to fill with blood between beats.

10.  How much can we increase muscle blood flow by altering muscle vascular resistance? 

Leave the heart rate at 190, but try changing the muscle vascular resistance from its initial value of 1 mmHg*s/mL.  What is the maximum muscle blood flow that you can get? At what resistance does that occur?  (Again, ignore any negative flows within the first half-second of the simulation, which simply represent the model settling into a stable parameter space.)


11.  Note that, in achieving extremely high flows in #10, arterial pressure falls quite a bit.  (By allowing the blood ejected from the heart to flow more quickly out of the arteries, you

get a lowered blood pressure.)  Low blood pressure can be a problem, especially since a certain amount of blood pressure is required to pump blood to regions of the body above the heart – like the brain!  

Let’s say that the average arterial blood pressure (midway between the peaks and valleys) must not fall below 80 mm Hg (to maintain blood flow to the brain).  What would your answer to #10 be if you included this additional constraint?

12.  Can increased gut resistance compensate for decreased muscle resistance?  Perhaps if we decrease blood flow to the gut, we can achieve a greater increase in blood flow to the muscles without sacrificing blood pressure.

If you are allowed to change both Gut Vascular Resistance and Muscle Vascular Resistance simultaneously away from their initial values, how high can muscle blood flow go while maintaining an average arterial pressure of at least 80 mm Hg?

Compare the current scenario to the situation at rest (when all parameters are at their original values, including a heart rate of 70).  How has blood flow to the muscles changed?  (Please give actual numbers.)  How has blood flow to the gut changed?

13.  Your gut needs blood flow in order to digest food.  In terms of resistances, how would you maximize blood flow to the gut after a big meal?  In light of these simulation results, why might it be a bad idea to do a hard workout immediately after a big dinner?

14.  This model of the human cardiovascular system is kind of a simple “no-brainer”: it doesn’t include a brain!  Let’s rectify that problem now by executing the following steps.


• Copy and paste the Muscle node (right-click => Copy, right-click => Paste).  This gives you another vascular bed with Volume, Flow, and Resistance properties.


• Rename the node "Brain."  Change the Brain’s initial vascular resistance to 10 mmHg*s/mL.


• Connect Arteries to Brain to Veins using the connector arrow ([image: image2.jpg]


) function.  Click on the connector arrow icon, then click on Arteries, then on Brain, then on Veins, and then elsewhere on the screen to stop the connecting spree.


• Go to the Arteries node.  Open the Properties panel.  Click on the EquationBlock property.  Change the equation for Volume:t to Volume:t= Aorta.Flow-Gut.Flow-Muscle.Flow-Brain.Flow; (The change in volume is equal to the inflow minus the outflow, which now includes the Brain.)


• Go to the Veins node.  Change the equation for Flow to Muscle.Flow+Gut.Flow+Brain.Flow.  In the equation block, change equation to Volume:t = Gut.Flow + Muscle.Flow + Brain.Flow - Heart.InFlow;


15.  The brain has some interesting physiological properties that distinguish it from the gut and the muscles.  Unlike the gut, the brain can't temporarily shut down when the muscles need energy; it needs to run continuously.  This poses some interesting problems for our system because the brain requires a nearly constant supply of blood (constant flow).  Additionally, the brain is especially sensitive to changes in blood pressure.  The brain vascular bed is sensitive to low pressure because the head is normally above the heart and aortic pressure needs to be high enough to drive the blood up against gravity; otherwise you will faint.  However, if the pressure is too high, excess fluid will drain out of the capillaries, and the brain can't handle this very well either.  (Standing on your head for long periods of time isn't pleasant.)  So we need a system that can rapidly shift flow between muscles and gut, while delivering nearly constant flow to the brain over a narrow pressure range.

During exercise, how would you maximize blood flow to the muscles while keeping arterial pressure between 80 and 150 mmHg and keeping blood flow to the brain at its normal value of 12-13 ml/sec?  (Suggestion: reset your Muscle and Gut resistance values to what they were initially, then try to find an optimal combination of values for Muscle, Gut, and Brain resistances.)  I’m essentially asking you to revise your previous answer to #11 in light of the need to include the brain and keep it happy.  Provide numbers from simulations to support your answer.
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