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UCINet is PC (Windows) software. It can be run on a Macintosh using a virtual PC 

operating system, such as VirtualBox. To run VirtualBox on the Sociolinguistics Laboratory 

MAC “Chesterton,” take the following steps: 

 

Running VirtualBox 

1. Launch the VirtualBox Desktop by clicking on its icon in the MAC dock (bottom of screen): 

 

 
 

2. Select which of the virtual machines that you want to run: currently, we have a Windows 7 

(“Racnoss”) and Windows 8 (“Argolin”) installation. Both installations run using the same 

version of UCINet, so the choice of installation is up to you. For this, guide, we will be using the 

Windows 7 32-bit version as the 32-bit version of UCINet is the version with more 

support/features. Click on Racnoss, then click the green “Start” arrow above it: 

 

 
 

3. This will open a new window that launches a Windows 7 “virtual machine.” Once the machine 

boots up, click the  “lab user” icon(  ) to start the Windows 7 verions. (This step is not 

necessary for the Windows 8/ “Argolin” installation.) 

 
The Macintosh and Windows operating systems are now both running on your computer. You can open a MAC 

application, as usual, by launching it from the dock. You can also launch Windows apps by clicking on the Start menu. 

While you are running the virtual desktop, and a PC application is active, the MAC Finder menu at the top of the screen 

will show “VirtualBox VM” as the active application. Click on a program’s window or use the MAC dock to “flip” 

between programs in the two platforms. 

 

 

4. At this point, there are two ways to launch UCINet: 
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 4a. Generally, you should be able to launch the program by double-clicking on the UCINet  

desktop icon: 

 
 

 4b. If for some reason the desktop icon is missing, you can navigate to the UCINet program 

directly by navigating to the UCINet folder at C:\Program Files\Analytic Technologies. The 

Ucinet 6 icon is in this folder; note that if you go into the folder called “Ucinet 6,” you will end 

up opening an older version of UCINet. This guide assumes you are running the latest version (at 

time of writing, 6.665). 

 

 If you are not familiar with doing this in Windows, here are the basic steps: (1) open the Start 

Menu, (2) click the “Computer” link in the right-most column in the Start Menu, (3) double-click 

the “Local Disk” icon in the screen that appears, (4) double-click the Program Files folder, (5) 

double-click the Analytic Technologies folder, (6) scroll down and double-click the UCINet icon.  

 

5. Launch UCINet. Do your work (refer to the rest of this guide). 

 

6. To end, exit Windows first. Select Shut down from the Start menu. Exit Virtual Box. If you 

are done working on Chesterton, log off the MAC. 
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1. Getting Started 

1.1 The UCINet Main window 

What you first see when you open UCINet is a white window with a set of menus 

with a limited toolbar just below it (Fig. 1).  

 
 

Fig. 1: the UCINET 6 main application window 

 

 

1.2 Main window icon functions 

The icons in the main application window toolbar, from left to right, allow you to: 
1. Exit 

2. Nothing; the Excel icon has been discontinued/no longer provides functionality 

but has not been removed by the developers. 

3. Open spreadsheet (“Matrix Editor”): 

a. Opens a blank UCINet spreadsheet 

b. From blank spreadsheet, you can select File > Open to open an existing 

readable file. (*.##h, *.##d are format types) 

4. Import a spreadsheet (Excel file) or a plain text file (.txt) into UCINet. 

5. Edit text file. Opens a blank Notepad (text) window into which data may be typed 

(note: for proper formatting, you must use heading conventions noted in manual). 

6. Display database: takes you to your default directory where UCINet databases are 

stored. Opens your database in Notepad as unformatted plain text. 

7. Open a Command Line Interface for working with UCINet. 

8. Display data in NetDraw (quickstart version) 

9. Display data in NetDraw: this launches an independent program bundled with 

UCINet that handles network graphing. 

 

2. Creating a Graph from Scratch 

 

2.1 Adjacency matrices 

This section explains how to create a simple case-by-case (or “adjacency”) matrix for a 

hypothetical group of individuals. This matrix contains the central relation information 

that forms the basis for any basic social network analysis. 

 

1. Generate a blank, unlabeled matrix, by clicking the Open spreadsheet (Matrix 

Editor) icon: 
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Your new spreadsheet is created in a second window, separate from the UCINet main 

application window.  

2. In the new application window, select the “Edit” drop-down from the top header and 

select “Set dimensions.” This will allow you to set the number of columns and rows 

that you want in your matrix: 

 
    Note that you can also use the “Edit” drop-down to add additional rows/columns as 

you work or click the “Change” button on the right-hand side of the window.  

3. Header information is entered in the gray cells at the rows and columns bordering the 

matrix. Beginning with the column of the first row (ignoring the outer-most rows 

which you cannot type into), type the names of your actors. Use the direction arrow 

keys or the TAB key to advance to the next row. 

 
 

4. You will want, since this is a square matrix, for your column names to duplicate your 

row names. This is easily done by selecting Labels, then copy rows to columns.  
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5. For a directed graph, you will fill in both in- and out-degrees. For an undirected graph, 

only the cells below the diagonal are completed: 

 

Undirected graphs: 

1. First, enter “-” in each diagonal cell. (Self-namings are not counted). 

 

2. For each cell, enter a “0” for unnamed ties, “1” for named ties. You can choose to 

do this by filling in just one side of the diagonal (top diagonal or bottom 

diagonal). In an undirected graph, it is the presence or absence of a link between 

actors that matters; the actor doing the naming doesn’t matter. 

 

3. For thought: how does one determine number of edges associated with a given 

actor from an undirected graph matrix? In many cases, you will manually count 

occurrences of 1’s across an actor’s row. But, you can also use the basis statistics 

functions in UCINet to do this (see §5.2 “Descriptive Statistics”, below) 

 

Directed graphs: 

1. First, enter “-“ in each diagonal cell. (Self-namings are not counted). 

 

We may consider the Rows to represent Outdegrees (read off as for example, “Ed 

directs a tie to...”) and the columns to reflect Indegrees (read off as, for example 

“... receives a tie from Ed.”) 

 

2. For each cell, enter a “0” for unnamed ties, “1” for named ties. 

 

3. Check your work:  

 - read down the columns to determine an individual’s indegrees. 

 - read across the rows to determine a speaker’s outdegrees. 

 - for thought: how does one determine number of edges from a directed graph 

matrix? 
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Valued Graphs 

1. Sometimes, you will want to distinguish types of ties (e.g., strong vs weak ties) 

using differential weightings. The most common way to do this in UCINet is to 

assign a numerical weight (0 to 5, -1 to 1, etc.) to a tie, and then use line weight or 

color to differentiate values in the published graph. 

 

2. Enter “0” for unnamed ties, as above. Enter weights, per your valuation scheme, 

for other ties. 

 

3. Follow instructions in §3.2 for highlighting different types of ties in a graph. You 

can also use these values to calculate centrality measures of different kinds. See 

§5, below. 

 

6. Save your work. Select File, then Save (or Save As...), then <filename>. UCINet 

defaults saving datafiles to C:\Users\lab user\Documents\UCINET data. The default file 

format is UCINet 4-6 dataset (with extension .##h) 

 

7. You will use NetDraw to draw the graph in your next section. 

 

3. Displaying a Graph in NetDraw 

 

3.1 Drawing a network diagram 

You create a matrix in UCINet, and then use the sister software package NetDraw 

(bundled with UCINet) to draw this matrix. The NetDraw main window has a 

subset of functions, but the pull-down menus allow you to execute a more extensive 

range of functions. Let’s open a sample UCINet network graph in NetDraw1: 

 

1. From the menus in the main UCINet window, choose Visualize > NetDraw. 

This action will launch the application NetDraw. You’ll see that there are two other 

graphics packages besides NetDraw whose graphs are readable by UCINet (Pajek and 

Draw). 

 

2. With NetDraw open, use the pulldown menus at top of screen (not buttons on toolbar), 

select: 

File > Open > UCINet dataset > Network 

 

Now, you should see a dialog box with several columns of information and an edit bar at 

the top. You want to browse to your desired file for this tutorial, using the button marked 

“…”, as shown in Fig. 2. 

 

File to select: KNOKBUR.##H 

File format: Ucinet 

Type of Data: 1-Mode Network(s) 

Options: ignore reflexive ties 

                                                 
1 NetDraw is an independent software application, made to run under UCINet. 
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Fig. 2: the Open Data dialogue box. 

 

This opens the following network graph: 

 

 
Fig. 3: The Knoke graph2 

 

 

 

Your network diagram should appear on the screen. Your matrix will still be open in its 

window. Note that making changes to the matrix will NOT cause the diagram to auto-

update. You must save the new datamatrix, and replot the diagram. 

                                                 
2 This graph displays exchange information among ten organizations that were involved in the local political economy 

of social welfare services in a Midwestern city (from a study by David Knoke). This graph contains arrowheads, which 

show the directions in which namings occurred in the dataset. This is therefore a directed graph. 

 



 9 

 

 

3. To print, you have to save your drawing in some graphic format, then print it using 

some MAC application (printer drivers will not be operational under VirtualBox, since no 

PC printer drivers have been installed on the lab’s MACs.) Below, we will demonstrate 

how to create and print a jpeg from MSWord. You may use other graphics formats and 

applications, of course. 

 

With NetDraw open, select File, then Save diagram as, then Jpeg. 

 

Save your work to the VirtualBox-Shared > UCINetData folder: 

 

 
 

Leave the VirtualBox (can be done by clicking on the MAC background) and open a 

MAC application, such as MS Word. 

 

Create a new document. 

 

Select Insert, then Picture..., then, From File... 
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The MAC OS Finder can see the Virtual Disk you have created, and from which you are 

running VirtualBox as a separate, mounted “volume.” While the VirtualBox is running, 

there is a shared folder where files can be passed between the MAC and the Windows 

instance. This shared folder is called “VirtualBox-Shared,” and can be seen/accessed 

from the Desktop: 

 

 
 

You can now use MSWord to print your jpeg. 

 

Select File, then print.   
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You can change graph properties using Attribute data. We have noted that UCINet 

is a little picky/finicky/ BUGGY with respect to attribute data. You apparently can’t 

create attribute data in a work session, and expect for those changes to stay so you 

can use them in your next session. You apparently have to save them to an attribute 

datafile (see section 3.3 “Saving attribute data”, below). 

 

 

3.2. Changing basic attribute information displayed on a NetDraw graph: 

Adding attributes to existing nodes in NetDraw 

The graph in Fig. 3 above has numbers, but no node labels. To add information that can 

be used for specifying node labels, select: 

Transform>Node attribute editor 

 

You can change the IDs associated with particular nodes here. Note that when the graph 

first opens, it uses built-in numbers (“internal IDs”) to keep track of existing nodes. You 

can’t delete these. 

 

You don’t change node values (internal IDs) in the Attribute Editor. You also do not 

change relational information here. 

 

Edit > Insert columns to the right 

 

Name your new attribute. In fact, let’s create 3: name, governmental status and specialist 

status (so, repeat the above process twice and use the three labels above to complete the 

table). Complete with data as shown: 

 

 
 

Then click File > Update and exit 
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You can now use your new attributes to selectively visualize your nodes. 

Properties>Nodes... 
- use >Labels>Text    ...to replace node IDs with data from Name attribute 

- use >Symbols>Color>Attribute-based ...to distinguish nodes with colors based on attribute 

- use >Rims...    ...to change rim styles 

 

Use Update and Exit after entering column data for the first time. For subsequent 

changes, go back to Transform > Node attribute editor and change information in the 

table. Then select File > Update and exit. You will then need to reclassify your data 

(using the Properties > Nodes… section above). 

 

3.3 Saving attribute data 

UCINet and NetDraw behave somewhat differently than you might expect regarding 

attribute data. It appears that in order to use attribute data, you actually have to set up an 

attribute database, close your attribute database and diagram and then REOPEN the graph 

and attribute datafile.  That is, if you create a diagram, assign attribute data, and end your 

session without creating an attribute database using the “save as” menu, your attribute 

data (including colors, shapes and line types) may not be reliably available to the present, 

and will not be available to any future, session. You will have to redo all formatting. So, 

to save your formatting: 

 

1) You will need to save your attribute database for the attribute data to be accessible to 

the software for graphing your network. Select File and then navigate to the following 

path: 

File>Save Data As>VNA 

 

2) Specify a name for the file and click “OK.” 

 

3) Important: RELOAD your attribute database and graph. 

a. File>Exit 

b. Relaunch NetDraw and Nagivate to File>Open>Vna text file>Complete and 

select your file. 

 

4) Your data, along with all visualization adjustments and changes to the Node attributes 

is now available to you as you saved it. 
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4. The Relations and Nodes Tabs 

Note: In this section, we are still in/using NetDraw with the Knoke data from 

Section 3. 

 

 
 

4.1. Relations Tab – use to show nodes connected by one or more defined relations 

Buttons 

 Dn: selects next defined relation for display in the main graph 

 Up: selects previous defined relation for display in the main graph 

 Cl:  show no relations (node symbols only) 

 All: show all relations simultaneously 

 R: appears to allow you to remove edges associated with a selected 

  Relation (same as you do by unchecking a box) 

 

Try this: 

 Using Dn/Up, select a relation to differentiate from the others in the list. Select 

Properties> Lines>Style>Relation-based. Select a line style, and then select one of the 

relations from the pulldown menu. 

 

4.2.  Highlighting certain “types” of relations in the graph 

 

You can show the ties in a graph as differing in color or line style depending on the type 

of relation. If you have recorded the two kinds of relation (e.g., different gender, same 

gender) as different relations in a multiplex graph, then use NetDraw to choose a 

different color for each of the relations you wish to graph. 
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4.2.1. Displaying ties by attribute information 

 

Line colors (but not styles) may also be used to highlight links within actors of the same 

type or between actors of different types, or both. Select Properties>Lines>Color>Node 

attribute-based. Then select whether you want to color the ties among actors of the same 

or different type, or both. Then use the drop-down menu to select the attribute you wish 

to graph. 

 

4.2.2. Displaying Strong/Weak Ties 

 

By color. We often measure the strength of a tie with an ordinal or interval level variable 

(ordinal: 0,1,2; interval: 1.1, 1.125, 3, -2, etc.).  You can assign colors to ties based on 

this value. Select Properties>Lines>Color>Tie-strength.  

 

By line thickness. If you have measured tie strength by a value, the magnitude of tie can 

be suggested by using thicker lines vs. thinner lines.  Select Properties>Lines>Size>Tie-

strength. Then select relation you want graphed. You can select the amount of gradation 

in the line widths (e.g. from 0-5 for a grouped ordinal variable with 6 levels; or from 5-10 

if you want really thick lines). 

E.g.,  

Negative-neutral-positive: -1, 0, 1 

Grouped ordinal:  5=very strong, 4= strong, 3= moderate, 2= weak, 1= very weak, 

0= absent 

Full-rank order:  10=strongest tie of 10, 9=second strongest tie of 10, etc. 

Interval:  e.g., dollars of trade from Belgium to the US in 1975 

 

4.2.3.  Displaying Ego networks 

 

You can show only those nodes related to a single actor (i.e., an ego-network).  
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To undo this, and return display to showing all nodes, select the Ego tab, and then Name 

from the pull-down menu. Check all boxes. 

 

 
 

4.2.4. Displaying intergroup networks 

 

Following Breiger (1988), we assume a group-by-group matrix contains information 

about how many groups connect members of an actor set, and the number of overlaps 

these groups show in membership. (Note: a group-by-group matrix will NOT tell us 

about the TOTAL size of a group, just the extent of intergroup overlaps.)  

 

If we have an actor-by-group matrix that tells us about the group memberships of all 

actors in our network, we can determine the actor-by-actor matrix and group-by-group 

matrices indirectly.  FIRST, return to the UCINET 6 Window (this step is not 

performed in NetDraw). Select: 

 

Network>Centrality and Power>2-mode centrality 

 

Note: this operation requires you to have separate matrices for the affiliation information, 

the centrality scores for both square matrices (the actor-to-actor and group-to-group 

matrices). One set of centrality scores are used as column values, and the second as row 

values. 

 

 

 

 

4.2.5 Transforming a 2-mode matrix (binary) into a 1-mode matrix 
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In a 1-mode matrix, both columns and rows refer to the same actors (and of course, actors 

will be of the same type, e.g., both rows and columns refer to people). In a 2-mode 

matrix, rows index one type of actor (e.g., people) while columns index another (e.g., 

speaker communities).  This type of representation is called affiliation data (info has been 

collected on a set of groups or events with which an actor is affiliated).  

 

Typical form: rows=actors; columns=affiliation 

 

We derive an adjacency (actor-by-actor) matrix by counting the number of groups or 

affiliations actors have in common. This is called the co-occurrence or co-membership 

matrix. And this co-membership matrix can be treated as normal data. 

 

We can also derive an event-by-event matrix counting the number of actors attending 

both events for every pair of events.  To generate the 1 mode matrix from the affiliation  

matrix, select: 

 

Data>Affiliations (2-mode to 1-mode) 

 

The set of output data will show scores ranging from 0-4. These values are automatically 

assigned to represent all logical possibilities among affiliations. Read the textfile to 

interpret the output values. 

NB- There is an older menu option of Affiliations (2-mode to 1-mode) [old]. This is not 

the option that you want. 
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5. Calculating Network Density and Multiplexity 

 

5.1 Density 

 

For a valued network (e.g., binary networks have values of “1” for named ties), density is 

defined as the sum of the ties divided by the number of possible ties (i.e. the ratio of 

all tie strength that is actually present to the number of possible ties).  The density of a 

network may give us insights into such phenomena as the speed at which information 

diffuses among the nodes, and the extent to which actors have high levels of social capital 

and/or social constraint.  

 

To calculate network density in UCINet, with the main application window open, select 

Network>Cohesion>Density>Density Overall. Select your datafile by clicking on the 

“...” button to the right of the Dataset Name field. The density calculation will be 

presented in a Notepad widow. UCI Net gives you the density of the network, and 

number of observed ties. The UCI Net output looks as follows (density value, which is 

52% in this example, is circled): 

 
DENSITY / AVERAGE MATRIX VALUE 

 ------------------------------------------------------------------------------

-- 

  

 Input dataset:                C:\Program Files\Analytic Technologies\Ucinet 

6\DataFiles\Joneses_adjacency 

 Output dataset:               C:\Program Files\Analytic Technologies\Ucinet 

6\DataFiles\Joneses_adjacency-density 

  

  

  

  

                               Density    No. of Ties 

                        -------------- -------------- 

     Joneses_adjacency          0.5165        94.0000 

  

  

 ---------------------------------------- 

 Running time:  00:00:01 

 Output generated:  29 Dec 08 17:03:45 

 Copyright (c) 1999-2008 Analytic Technologies 

 

5.2  Descriptive Statistics 

 

Use Tools>Univariate Stats (do not use _Univariate Stats [old]!) provides quick 

summaries of the distribution of actor's ties. This procedure computes mean, standard 

deviation, variance, Euclidean norm, maximum, minimum and total number of 

observations for each row or column of a matrix, or for the matrix taken as a whole. 

Sample data for the same matrix as provided above, appears below: 
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UNIVARIATE STATISTICS 

------------------------------------------------------------------------------- 

  

 Dimension:                    COLUMNS 

 Diagonal valid?               NO 

 Input dataset:                C:\Program Files\Analytic Technologies\Ucinet 6\DataFiles\Joneses_adjacency 

  

  

 Descriptive Statistics 

  

                    1      2      3      4      5      6      7      8      9     10     11     12     13     14 

               Bee Jo Cece J Letiti Charle Mary J Fanny  Paul S Ferdin Patric Bill P Young  Lee Si Bert B Stan L 

               ------ ------ ------ ------ ------ ------ ------ ------ ------ ------ ------ ------ ------ ------ 

   1     Mean   0.308  0.385  0.154  0.769  0.923  0.462  0.308  0.846  0.615  0.385  0.692  0.308  0.538  0.538 

   2  Std Dev   0.462  0.487  0.361  0.421  0.266  0.499  0.462  0.361  0.487  0.487  0.462  0.462  0.499  0.499 

   3      Sum   4.000  5.000  2.000 10.000 12.000  6.000  4.000 11.000  8.000  5.000  9.000  4.000  7.000  7.000 

   4 Variance   0.213  0.237  0.130  0.178  0.071  0.249  0.213  0.130  0.237  0.237  0.213  0.213  0.249  0.249 

   5      SSQ   4.000  5.000  2.000 10.000 12.000  6.000  4.000 11.000  8.000  5.000  9.000  4.000  7.000  7.000 

   6    MCSSQ   2.769  3.077  1.692  2.308  0.923  3.231  2.769  1.692  3.077  3.077  2.769  2.769  3.231  3.231 

   7 Euc Norm   2.000  2.236  1.414  3.162  3.464  2.449  2.000  3.317  2.828  2.236  3.000  2.000  2.646  2.646 

   8  Minimum   0.000  0.000  0.000  0.000  0.000  0.000  0.000  0.000  0.000  0.000  0.000  0.000  0.000  0.000 

   9  Maximum   1.000  1.000  1.000  1.000  1.000  1.000  1.000  1.000  1.000  1.000  1.000  1.000  1.000  1.000 

  10 N of Obs  13.000 13.000 13.000 13.000 13.000 13.000 13.000 13.000 13.000 13.000 13.000 13.000 13.000 13.000 

  

 Statistics saved as dataset   C:\Program Files\Analytic Technologies\Ucinet 6\DataFiles\Joneses_adjacency-Uni 

  

 ---------------------------------------- 

 Running time:  00:00:01 

 Output generated:  29 Dec 08 17:11:03 

 Copyright (c) 2002-8 Analytic Technologies 
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5.3  Multiplexity 

 

5.3.1. Creating a multiplex (multirelational) dataset. 

 

Multiplex data are data that describe multiple relations (sometimes called “multi-stranded 

relations”) among the same set of actors.  Examples of relations or “activity fields” 

include: kinship, occupation, leisure activity, participation in organized or informal 

events (e.g., “PTA”, “class of 2008”, swing dance group). A multiplex relation would 

occur when the same pair of actors know each other in more than one capacity (e.g., PTA 

and swing dance). The ties can be directed or not; and the relations can be recorded as 

binary, multi-valued nominal, or valued (ordinal or interval). 

 

The most common structure for multiplex data is a set of actor-by-actor matrices (or 

"slices"), one for each relation.  To designate different relations in this way, create a 
separate matrix for each relation (e.g., “talks to,” “confides in”, “kin of”).  Each 
relation can be opened independently in NetDraw, as done above in §3. You can choose 
to calculate multiplexity using UCINet (which you inspect in an output textfile—no 
graph). Or you can open graphs showing multiple relations in NetDraw itself 
(see §5.3.2, below). 

 
5.3.2.  Viewing multirelational data. 
 
Unfortunately, at the printing of this handbook, the one crucial function unavailable in 
NetDraw is viewing of multiplex relations in a manner where two nodes can be 
connected with several strands.  That is, you cannot presently look at a graph and tell 
that a tie is multiplex.  You have the option of assigning (by-hand) weights to ties, and 
then distinguishing multiplex ties from uniplex ones by line thickness, or different color, 
etc.  In other words, if you set tie values, you may visually differentiate ties of different 
value. In addition, you can show ties constituted in different relations using show/hide:  
Show/Hide relations by clicking their box in the relations tab. 
 
Visualization of tie values 
To assign weights to ties, make sure the cells in the matrix representing tie values have 
numerical values (e.g., 1,2,3) that can meaningfully reflect tie strength.  
 
In NetDraw, open the matrix. Then, select 

Properties > Lines > Size > TieStrength 
Select the relation whose tie values should be weighted. The graph should now change to 
reflect tie weights. This function, unfortunately, produces inconsistent results in UCINet 
V, so some researchers prefer to set node size to reflect tie strength (e.g., larger nodes, 
greater strength). 
 
Opening graphs showing multiplex relations 
You can open multiple graphs in NetDraw. You should have previously created several 
relation matrices defining  different relations for the same set of actors (listing these in 
the same order on all matrices). You simply open each matrix, one at a time, in NetDraw: 

File > Open > UCINet dataset > One-mode network 
Each matrix will be listed in the Relations box at the right of the screen. You may assign 
different colors to the lines drawn for each relation (Properties > Lines > Color). 
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Note that you will only be able to see one color at a time, as different lines will all be 
stacked on top of each other. You may, however, deselect a relation in the relations box 
to show only one relation at a time to confirm which ties are observed for a relation. You 
may print these “one at a time” relation views. 
  
5.3.3. Calculating network multiplexity. 
 
We measure multiplexity by joining datasets. To join datasets, enter the UCINet main 
window. Select Data>Join>Join matrices Select the two files you wish to join. The 
output filename is shown in the window at the bottom of the pane. Once the file has been 
created, you can use Transform>Graph Theoretic>Multiplex to view multiplexity 
information. A super sociomatrix is generated which contains a numerical value for 
every observed relation combination beween actors. So, if your dataset joins two 
matrices, each of which had binary values, the new supersociomatrix will have 4 values 
as follows (if all four combinations were observed): 
 
0= 0 on relation 1, and 0 on relation 2 (no tie between these actors at all) 
1= 1 on relation 1, 0 on relation 2 
2= 1 on relation 1, and 1 on relation 2 
3= 0 on relation 1, 1 on relation 2  
 
5.3.4. Estimating other network properties 
 
View centrality properties of the actors. In NetDraw (not UCINet), select 
Analysis>Centrality Measures. Select all types of centrality you wish to use to 
partition the data for viewing (e.g., betweeness, closeness, degree, etc.).  These are added 
as nodal attributes to the list of attributes you created (and data are saved to your tab-
delineated attribute database). Select the Nodes tabon the right edge of the NetDraw 
window, pull down the menu to view each type of centrality or attribute. The default is to 
treat different values (e.g., for degree centrality, numbers in checkbox list represent 
outcome values for degree) with different colors. Click the checkboxes to show/hide 
different subsets of structurally-equivalent actors. 
 

 

 

6. Other Functions 

 

Layout>Random Algorithm locates nodes randomly in the X-Y space (you can use 

other tools to change the size of the graphic, rotate it, etc. Since the X and Y 

directions don’t mean anything, the location of the nodes and relations don’t 

provide any particular insight. 

 

Layout>Attributes as Coordinates  User can assign X and Y dimensions of attributes to 

scores on attributes, then select attributes to be assigned to X or Y or both. Useful 

for exploring how patterns of ties differ within and between “partitions” (or types 

of nodes). 

 

Structural equivalence:  Identifying structurally similar actors  

p. 37: “one can use UCINET (or other programs) to identify “types” of actors based on 

their relations (e.g. where are the cliques?), and then enter this information into the 
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attribute editor of NetDraw...The groupings that are created by using Analysis tools 

already built-in to NetDraw are automatically added to the node attribute database.” 

 
Other commands for assessing positional and structural equivalence: 
 
Transform>Block 
Transform>Symmetrized 
Network>Roles & Positions 
Network>Centrality   
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7. Types of datafiles 

 

Attribute data file:  has columns of attributes 

Network data file: has relational information 

 

Mage 

Program allowing 3-dimensional rendering and rotation 

 

 

8. UCI Net Quirks and Bugs 

 

8.1. Saving your diagram formatting 

This problem is discussed in detail in §4, above “Saving your attribute data.” Although 

you may save an attribute database that NetDraw can use to assign attribute data to nodes, 

specific colors, sizes, rim types and shapes are NOT apparently able to be saved from 

session to session. That is, if you create a diagram in a Net Draw session, your formatting 

will be lost once NetDraw is closed. When you next open the diagram, it will be 

necessary to adjust your formatting. The distinctions you created will be saved (there will 

be different colors distinguishing different levels of a variable, for example). These just 

won’t be distributed the same way you set them up in that last session unless you save 

your attribute data to a separate attribute database file. 

For UCINet 6, I have not been able to replicate this issue. However, I have found that 

saving your visualization as attribute data, and not as a vna file, results in the attributes 

file not being able to be re-aligned with the UCINet file when you reload them. This is 

why this version of the guide suggests saving your visualization as a .vna file and 

reloading it as a “Complete” VNA file in UCINet/NetDraw. (This appears to be a known 

bug for Virtual Machine installations, but the usual fixes have not worked with our 

versions as of the time this guide was written.) 
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Appendix 

 

Building a (Readable) Social Network Graph in UCINet and NetDraw 

by: Rachel E. Schirra (December, 2008) 

 

Organizing Actor Attributes 

Social network graphs can be very informative, but it can be difficult to include 

all the actor attributes that are pertinent without the graph getting extremely complex. 

In this network graph I found that there were many attributes I felt were important 

and wanted to make readily apparent to people looking at the graph: 

1. Gender of actor 
2. How long actor has known ego 
3. Strength of tie between actor and ego 
4. Type of relationship between actor and ego (e.g. service transaction, 

family, classmate) 

I chose to indicate this information as follows: 

1. Gender of actor is indicated by the color of the node: red for females, 
blue for males, black for neuter since I had some “actors” that were 
actually mixed-gender groups. 

2. How long the actor has known ego is indicated by the node’s distance 
from ego, with the actors who have known ego longest closest to the 
center. Several age ranges are specified, and these are marked in the 
background of the graph as concentric circles, with darker circles 
indicating a longer relationship with ego. 

3. Strength of tie between actor and ego is indicated via node size, with 
larger nodes indicating a stronger tie. 

4. Type of relationship between actor and ego is indicated by position on 
the graph and by the color of the background where the node appears. 
Different types of relationships appear on backgrounds of a different 
color, i.e. green for service transactions and pink for classmates. 

 

Making the Graph 

1. Enter data into UCINet. 
Create a sociomatrix in UCINet indicating the relationships between the 
actors. 
 

2. Add actor attribute data. 
Open the sociomatrix in NetDraw, and use the Node Attribute Editor 
(Transform > Node Attribute Editor) to add attribute data for your actors. In 
this case I created attribute fields for gender, time known, tie strength, and 
activity field. For convenience I assigned a number to each possible attribute 
setting, i.e. 1 for female and 2 for male. 
When you’re finished, update your data and exit the Node Attribute Editor 
(File > Update and Exit). Don’t forget to save your attribute data after you 
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exit the editor so you can open it again later. (File > Save Data As > UCINet > 
Attributes). N.B.- As of 2018, this has not worked when reloading the files, 
hence the recommendation in the main guide to save as a .vna file. 
 

3. Change the look of your nodes. 
Now that you’ve applied the node attribute data to your graph you can use 
the attributes you set to change how actors’ nodes look depending on their 
attributes. For this graph I indicated gender by node color (Properties > 
Nodes > Symbols > Color > Attribute-based). You can do this by selecting 
“Gender” for the attribute. Then assign a color to each of your gender 
variables (or use the ones UCINet assigns for you). 
I also used node size to indicate tie strength (Properties > Nodes > Symbols > 
Size > Attribute-based). Like above, select the attribute, and then assign 
maximum and minimum node sizes. This works best if you’ve given numbers 
as your variables – I used a range from 1 for the weakest ties and 4 for the 
strongest. 
 

4. Arrange the nodes by activity field. 
This is the tricky part: I wanted nodes in the same activity field to be near 
each other on the graph. NetDraw includes a function to do this (Layout > 
Group by Attribute > Categorical Attribute), but the output isn’t pretty: 

 
Fortunately it’s possible to make an easier to read graph that takes into 
account the current positions of the nodes, so it will keep nodes in different 
groups together. Use the Spring-Embedding layout function (Layout > Graph-
Theoretic Layout > Spring Embedding), and make sure you have the “Starting 
positions” option set to “Current positions”. This should result in a much 
more attractive arrangement, although you may still need to move nodes 
around by hand so their names don’t overlap: 
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5. Arrange nodes by time known. 
Unfortunately I couldn’t find a way to arrange the nodes by time known and 
by activity field simultaneously. Instead I did this part by hand: I moved the 
actors who had known ego the longest closer to the center, and those who 
had known ego for the shortest amount of time farther out. The important 
part is to leave the nodes in the same general vicinity so that the nodes in the 
same activity field stay together. 
 

6. Save your network graph as an image file. 
Make an image file of your network graph (File > Save Diagram As). You can 
save as a JPEG (File > Save Diagram As > Jpeg) or a bitmap (File > Save 
Diagram As > Bitmap), but a bitmap works better if you want to color-code 
the background. 
 

7. Color-code the activity fields. 
NetDraw doesn’t include a way to alter the background of your network 
graph, so in order to make different activity fields different colors it is 
necessary to open the network graph image in an image editor and modify it 
from there. The exact way to do this varies depending on the software you 
use.  
To color-code the activity fields I made wedges in different colors that 
radiated out from ego and included all the actors in that activity field. 
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8. Shade the time-known regions. 
Since I coded time-known not continuously but as one of four discrete values, 
I marked these categories on the graph also. This was also done in an image 
editor. I made concentric circles corresponding to the different values for the 
“time known” variable, with darker circles toward the center. By making the 
circles partially transparent, I was able to make the activity field color visible 
as well. 
N.B.- While I don’t know what image editor was used in this instance, it is 
possible to achieve similar effects in many different ones. Adobe 
Photoshop, the Gnu Image Manipulation Program, or even MS Paint 
would allow you to do this manually. 
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9. Make a key and label the activity fields. 

I opted to include a key at the bottom of the graph explaining what the 
different colors and symbols indicated. I also gave each activity field a text 
label so it would be readily apparent what each color was supposed to 
represent.  
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